Back to overview
Degraded

Cannot Establish Video Connectoins

Oct 19 at 10:30pm HDT
Affected services
lookdeep.ai

Resolved
Oct 20 at 10:46am HDT

Our engineering and operations teams worked closely with AWS’s incident response unit to monitor the outage, validate its impact on our platform, and ensure timely service restoration. Our systems came up automatically without delay once AWS services were online. Most customers were impacted for 1-4 hours and not able to establish a video connection to devices.

While the incident was outside of our direct control, we take responsibility for the disruption to your experience and operations.

Created
Oct 19 at 10:30pm HDT

A recent application outage that affected the LookDeep platform on October 20, 2025 12:11 AM PT. This disruption was caused by a broader issue with Amazon Web Services (AWS), which impacted several of their services across multiple customers globally.

What Happened
At approximately 12:11am PT, our systems experienced an unexpected disruption due to an infrastructure failure within AWS’s networking stack. This led to the inability to establish video connection for some of our customers.